美文网首页
A hard puzzle

A hard puzzle

作者: pro_ven_ce | 来源:发表于2017-06-28 19:53 被阅读16次

传送门

Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output

For each test case, you should output the a^b's last digit number.
Sample Input
7 66
8 800

Sample Output

9
6

算最后一位数取余就好了,找到规律,发现最多4次一个循环

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{    int a,b,c[4]; 
  while(cin>>a>>b)  
  {     
      a=a%10;
      c[0]=a;//一次方的末尾数    
      c[1]=(c[0]*a)%10;//二次方的末尾数
      c[2]=(c[1]*a)%10;//三次方的末尾数
      c[3]=(c[2]*a)%10;//四次方的末尾数    
      if(b%4==1)        
          cout<<c[0]<<endl;
      if(b%4==2)    
          cout<<c[1]<<endl;
      if(b%4==3)         
          cout<<c[2]<<endl;
      if(b%4==0)         
          cout<<c[3]<<endl; 
  }    
  return 0;
}

相关文章

  • A hard puzzle

    传送门 Description lcy gives a hard puzzle to feng5166,lwg,J...

  • 52. N-Queens II N皇后 ||

    题目链接tag: Hard; question:  The n-queens puzzle is the prob...

  • LeetCode专题-深度优先搜索(二)

    目录 N皇后问题一、二 51. N-Queens Hard The n-queens puzzle is the ...

  • 2018-07-16

    Amusing Jigsaw Puzzle is funnny puzzle game. PLay it and ...

  • AnimalMosaic

    This is a puzzle puzzle game for children, let children f...

  • 一些诗记录

    The Puzzle You turned and walked awayLeft a puzzle for me...

  • 2018-07-23

    ET Sweet Puzzle Welcome to the ORIGINAL ET Sweet Puzzle a...

  • Puzzle

    最近玩猜谜比较多,谜底首尾相连。如此出题很累,许多尾字不好接的词也被弃用。我和里兄商量,何不像真正的填字游戏那样出...

  • Puzzle

    昨日我们在博雅MBA社群,开启了有史以来不一样的用膳时光。为何这样说?首先是本次都是刘老师和罗汉们亲自下厨,选取...

  • Puzzle

网友评论

      本文标题:A hard puzzle

      本文链接:https://www.haomeiwen.com/subject/jeqpcxtx.html