1004. Counting Leaves (30)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input
2 1
01 1 02
Sample Output
0 1
2、说明
1)辛辛苦苦从0开始,还特别容易出错,不如直接使用成熟的算法,明天继续这道题
3、代码
#include<iostream>
#include<algorithm>
#define N 101
using namespace std;
typedef struct Node {
int level;
bool bool_child=false;
}node;
int main() {
int n, m;
scanf("%d %d", &n, &m);
int i, j, k,l;
int a, b, c;
int max_level = 1;
node tree[N];
//读入所有数据
for (i = 0;i < m;++i) {
scanf("%d %d", &j, &k);
//对01节点特殊处理
if (j == 1) {
tree[j].level = 1;
tree[j].bool_child = true;
}
else {
tree[j].bool_child = true;
}
for (l = 0;l < k;++l) {
scanf("%d", &a);
tree[a].level = tree[j].level + 1;
max_level = tree[a].level;
}
}
//查找每个level的叶节点的数量
int num;
for (i = 1;i <= max_level;++i) {
num = 0;
for (j = 1;j <= n;++j) {
if (tree[j].level == i) {
if (tree[j].bool_child == false) {
num++;
}
}
}
if (i != 1)
printf(" ");
printf("%d",num);
}
system("pause");
return 0;
}
网友评论