输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z
问题链接:https://vjudge.net/problem/hdu-2000
问题简述:多次进行输入初始化长度为3的字符数组并且按大到小输出
问题分析:
1.多次进行采用while一直输入多次
2.采用冒泡排序对一个数组进行排序
3.输出注意空格位置,先输出第一个,再for循环输出空格加字符元素
程序说明:
程序如下:
#include<iostream>
using namespace std;
void swap(char&p1, char&p2
{
char p3 = p1;
p1 =p2;
p2 = p3;
}
int main()
{
char a[3];
while (cin >> a[0] >> a[1] >> a[2])
{
for (int lunci = 1; lunci < 3; lunci++)
{
for (int i=0; i < 2; i++)
{
if (a[i] > a[i + 1])swap(a[i], a[i + 1]);
}
}
cout << a[0];
for (int i = 1; i < 3; i++)
{
cout << ' ' << a[i];
}
cout << endl;
}
}
网友评论