美文网首页
UVa 489 Hangman Judge 刽子手游戏 pyth

UVa 489 Hangman Judge 刽子手游戏 pyth

作者: 驰骛 | 来源:发表于2018-05-08 13:43 被阅读0次

    原题链接

    1. 题目:

    In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

    1. The contestant tries to solve to puzzle by guessing one letter at a time.
    2. Every time a guess is correct, all the characters in the word that match the guess will be “turned over.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution will be counted as “solved”.
    3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.
    4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
    5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
    6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

    Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

    Input
    Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of ‘-1’ would indicate the end of all games (and input).

    Output
    The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:
    You win.
    You lose.
    You chickened out.

    Sample Input
    1
    cheese
    chese
    2
    cheese
    abcdefg
    3
    cheese
    abcdefgij
    -1

    Sample Output
    Round 1
    You win.
    Round 2
    You chickened out.
    Round 3
    You lose.

    2. 要点:

    • 把solution字符串写入为set集合类,能有效减少对原字符串重复字符的检索判断
    • 对于guess字符串,可用数组保存已检测的字符,用来剔除重复字符。不能将其先设为set集合类再变为list列表类(list(set(s1))),因为set无序,再变为列表时顺序被打乱,影响检测次序,使结果出现偏差
    • 当机会用完(chance == 0)或者已猜出全部字符(left == 0),提前跳出循环,避免chance变为负值或者无效的循环检测
    • 注意输出格式

    3. 代码:

    #! python3 
    
    Round = input()
    while Round != '-1':
        s = set(input())
        s1 = input()
        left = len(s)
        chance = 7
        buff = []
        for i in range(len(s1)):
            
            #ignore detected characters
            if s1[i] in buff:
                continue
            buff.append(s1[i])
            
            if not chance or not left:          
                break
            if s1[i] in s:
                left -= 1
            else:
                chance -= 1     
        print('Round %s' % (Round)) 
        if not left:
            print('You win.')
        elif not chance:
            print('You lose.')
        else:
            print('You chickened out.')         
        Round = input()
    

    相关文章

      网友评论

          本文标题:UVa 489 Hangman Judge 刽子手游戏 pyth

          本文链接:https://www.haomeiwen.com/subject/olwirftx.html