美文网首页
1292: Boy or Girl

1292: Boy or Girl

作者: Celia_QAQ | 来源:发表于2019-04-02 14:59 被阅读0次

Time Limit: 1 SecMemory Limit: 128 MB

Submit: 438Solved: 312

[Submit][Status][Web Board]

Description

Those days, many boys use beautiful girls' photos as avatars in  forums. So it is pretty hard to tell the gender of a user at the first  glance. Last year, our hero went to a forum and had a nice chat with a  beauty (he thought so). After that they talked very often and eventually  they became a couple in the network.

But yesterday, he came to see "her" in the real world and found out  "she" is actually a very strong man! Our hero is very sad and he is too  tired to love again now. So he came up with a way to recognize users'  genders by their user names.

This is his method: if the number of distinct characters in one's  user name is odd, then he is a male, otherwise she is a female. You are  given the string that denotes the user name, please help our hero to  determine the gender of this user by his method.

Input

Every line contains a non-empty string, that contains only lowercase  English letters — the user name. This string contains at most 100  letters.

Output

If it is a female by our hero's method, print "CHAT WITH HER!" (without the quotes), otherwise, print "IGNORE HIM!" (without the quotes).

Sample Input

wjmzbmr

xiaodao

sevenkplus

Sample Output

CHAT WITH HER!

IGNORE HIM!

CHAT WITH HER!


主要输入的字符串会有重复的字符,如果单纯地用strlen()肯定不行的它会把重复的也算上,那我们就排序之后再判断第i个与第i+1个是否一样就行了

参考:Boy or Girl - 聪明绝顶的你与即将秃头的我 - CSDN博客


AC代码:

#include<stdio.h>

#include<algorithm>

#include<iostream>

#include<string.h>

using namespace std;

int main(){

int repeat;

char a[200];

while(~scanf("%s",a))

{

int len=strlen(a);

sort(a,a+len);

int sum=0;

for(int i=0;i<len;i++)

if(a[i]!=a[i+1]) sum++;

if(sum%2==0)

printf("CHAT WITH HER!\n");

else

printf("IGNORE HIM!\n");

}

return 0;

}

相关文章

网友评论

      本文标题:1292: Boy or Girl

      本文链接:https://www.haomeiwen.com/subject/psrgbqtx.html