美文网首页HackerRank
HackerRank:2D Array - DS Python3

HackerRank:2D Array - DS Python3

作者: 流浪山人 | 来源:发表于2019-11-09 17:32 被阅读0次

    题目

    Given a 2D Array, :

    1 1 1 0 0 0
    0 1 0 0 0 0
    1 1 1 0 0 0
    0 0 0 0 0 0
    0 0 0 0 0 0
    0 0 0 0 0 0
    
    

    We define an hourglass in to be a subset of values with indices falling in this pattern in 's graphical representation:

    a b c
      d
    e f g
    
    

    There are hourglasses in , and an hourglass sum is the sum of an hourglass' values. Calculate the hourglass sum for every hourglass in , then print the maximum hourglass sum.

    For example, given the 2D array:

    -9 -9 -9  1 1 1 
     0 -9  0  4 3 2
    -9 -9 -9  1 2 3
     0  0  8  6 6 0
     0  0  0 -2 0 0
     0  0  1  2 4 0
    
    

    We calculate the following hourglass values:

    -63, -34, -9, 12, 
    -10, 0, 28, 23, 
    -27, -11, -2, 10, 
    9, 17, 25, 18
    
    

    Our highest hourglass value is from the hourglass:

    0 4 3
      1
    8 6 6
    
    

    Note: If you have already solved the Java domain's Java 2D Array challenge, you may wish to skip this challenge.

    Function Description

    Complete the function hourglassSum in the editor below. It should return an integer, the maximum hourglass sum in the array.

    hourglassSum has the following parameter(s):

    • arr: an array of integers

    Input Format

    Each of the lines of inputs contains space-separated integers .

    Constraints

    Output Format

    Print the largest (maximum) hourglass sum found in .

    Sample Input

    1 1 1 0 0 0
    0 1 0 0 0 0
    1 1 1 0 0 0
    0 0 2 4 4 0
    0 0 0 2 0 0
    0 0 1 2 4 0
    
    

    Sample Output

    19
    
    

    Explanation

    contains the following hourglasses:

    image

    The hourglass with the maximum sum () is:

    2 4 4
      2
    1 2 4
    

    简要介绍

    从一个6*6的数组中找出sum和最大的漏斗,漏斗固定为313的形状

    Answer

    #!/bin/python3
    
    import math
    import os
    import random
    import re
    import sys
    
    # Complete the hourglassSum function below.
    def hourglassSum(arr):
        m=-100 # 不要设置为0,如果所有的数字都是负数,testcase会挂
        for i in range(0,4):
            for j in range(0,4):
                sum=0
                sum=arr[i][j]+arr[i][j+1]+arr[i][j+2]+arr[i+1][j+1]+arr[i+2][j]+arr[i+2][j+1]+arr[i+2][j+2]
                m=max(sum,m)
        return(m)
    
    if __name__ == '__main__':
        fptr = open(os.environ['OUTPUT_PATH'], 'w')
    
        arr = []
    
        for _ in range(6):
            arr.append(list(map(int, input().rstrip().split())))
    
        result = hourglassSum(arr)
    
        fptr.write(str(result) + '\n')
    
        fptr.close()
    

    相关文章

      网友评论

        本文标题:HackerRank:2D Array - DS Python3

        本文链接:https://www.haomeiwen.com/subject/pzynbctx.html