美文网首页HackerRank
HackerRank:Arrays: Left Rotation

HackerRank:Arrays: Left Rotation

作者: 流浪山人 | 来源:发表于2019-11-09 18:23 被阅读0次

    题目

    A left rotation operation on an array shifts each of the array's elements unit to the left. For example, if left rotations are performed on array , then the array would become .
    Given an array of integers and a number, , perform left rotations on the array. Return the updated array to be printed as a single line of space-separated integers.
    Function Description
    Complete the function rotLeft in the editor below. It should return the resulting array of integers.
    rotLeft has the following parameter(s):
    An array of integers .
    An integer , the number of rotations.
    Input Format
    The first line contains two space-separated integers and , the size of and the number of left rotations you must perform.
    The second line contains space-separated integers .
    Constraints
    Output Format
    Print a single line of space-separated integers denoting the final state of the array after performing left rotations.
    Sample Input
    5 4
    1 2 3 4 5
    Sample Output
    5 1 2 3 4
    Explanation
    When we perform left rotations, the array undergoes the following sequence of changes:
    Change Theme

    简要介绍

    就是数据移动,给出一个数组,给出向左移动的个数,解题思路 位置加上移动次数除以数组长度,就是移动后数据的位置

    Answer

    #!/bin/python3
    
    import math
    import os
    import random
    import re
    import sys
    
    # Complete the rotLeft function below.
    def rotLeft(a, d):
        res=[]
        for i in range(0,len(a)):
    
            n=(i+d)%len(a)
            res.append(a[n])
        return res
    
    if __name__ == '__main__':
        fptr = open(os.environ['OUTPUT_PATH'], 'w')
    
        nd = input().split()
    
        n = int(nd[0])
    
        d = int(nd[1])
    
        a = list(map(int, input().rstrip().split()))
    
        result = rotLeft(a, d)
    
        fptr.write(' '.join(map(str, result)))
        fptr.write('\n')
    
        fptr.close()
    
    

    相关文章

      网友评论

        本文标题:HackerRank:Arrays: Left Rotation

        本文链接:https://www.haomeiwen.com/subject/zkmnbctx.html