1013. Battle Over Cities (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
2、思路
1)寻找独立区域数量;
2)使用深度优先;
3)注意:以后数组(i=1;i<=n;++i)好了,变来变去好乱。
3、代码
#include<iostream>
#define N 1001
#define INF 999999
using namespace std;
int n, m, k;
int book[N] = {0}, a[N][N];
//深度优先,寻找独立节点的数量
void dfs(int x) {
int i, j;
for (i = 1;i <= n;++i) {
if (a[x][i] == 1 && book[i] == 0) {
book[i] = 1;
dfs(i);
}
}
return;
}
int main() {
int i, j, l;
int b, c;
int num = 0;
cin >> n >> m >> k;
//初始化
for (i = 1;i <= n;++i) {
for (j =1;j <= n;++j) {
if (i == j) a[i][j] = 0;
else a[i][j] = INF;
}
}
//读入数据
for (i = 1;i <= m;++i) {
scanf("%d %d", &b, &c);
a[b][c] = 1;
a[c][b] = 1;
}
//读入被破坏的城市并处理
for (i = 1;i <= k;++i) {
scanf("%d", &b);
for (j = 1;j <= n;++j)
book[j] = 0;
num = 0;
book[b] = 1;
for (j = 1;j <= n;++j) {
if (book[j] == 0) {
dfs(j);
++num;
}
}
printf("%d\n", num-1 );
}
system("pause");
return 0;
}
网友评论