美文网首页
PAT Advanced 1019. General Palin

PAT Advanced 1019. General Palin

作者: OliverLew | 来源:发表于2019-05-24 14:02 被阅读0次

    我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

    题目

    A number that will be the same when it is written forwards or backwards is
    known as a Palindromic Number. For example, 1234321 is a palindromic
    number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system,
    the concept of palindromicity can be applied to the natural numbers in any
    numeral system. Consider a number N > 0 in base b \ge 2 , where it is
    written in standard notation with k+1 digits a_i as \sum_{i=0}^k (a_ib^i) . Here, as usual, 0 \le a_i < b for all i and a_k is non-zero.
    Then N is palindromic if and only if a_i = a_{k-i} for all i . Zero is
    written 0 in any base and is also palindromic by definition.

    Given any positive decimal integer N and a base b , you are supposed to
    tell if N is a palindromic number in base b .

    Input Specification:

    Each input file contains one test case. Each case consists of two positive
    numbers N and b , where 0 < N \le 10^9 is the decimal number and 2 \le b \le 10^9 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line Yes if N is a palindromic
    number in base b , or No if not. Then in the next line, print N as the
    number in base b in the form " a_k a_{k-1} ... a_0 ". Notice that
    there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    

    Sample Output 1:

    Yes
    1 1 0 1 1
    

    Sample Input 2:

    121 5
    

    Sample Output 2:

    No
    4 4 1
    

    鸣谢网友“CCPC拿不到牌不改名”修正数据!

    思路

    综合考察进制转换和回文数检查,两个都相对简单,大家可以直接看代码。

    代码

    最新代码@github,欢迎交流

    #include <stdio.h>
    
    int main()
    {
        int N, b, c, isPalindromicNumber = 1, b_base[30] = {0};
    
        scanf("%d %d", &N, &b);
    
        /* Calculate N in b-base */
        for(c = 0; N; N /= b, c++)
            b_base[c] = N % b;
    
        /* Check if it is palindromic number */
        for(int i = 0; i < c / 2; i++)
            if(b_base[i] != b_base[c - i - 1])
                isPalindromicNumber = 0;
        puts(isPalindromicNumber ? "Yes" : "No");
    
        if(c == 0)
            printf("0");
        /* Reversely printing is the correct order */
        while(c--)
            printf("%d%c", b_base[c], c ? ' ' : '\0');
    
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:PAT Advanced 1019. General Palin

          本文链接:https://www.haomeiwen.com/subject/qvaxeqtx.html