美文网首页
PAT1003 Emergency (25)(Dijkstra算

PAT1003 Emergency (25)(Dijkstra算

作者: yestinl | 来源:发表于2019-04-20 15:32 被阅读0次

    题目

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) – the number of cities (and the cities are numbered from 0 to N-1), M – the number of roads, C1 and C2 – the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
    All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1

    Sample Output

    2 4

    分析题目

    题目要求的是最短路径,以及点权值的加权,用Dijkstra算法

    学习Dijkstra算法

    此处参考了从杰的透彻理解地杰斯特算法

    图1
    如图1,
    步骤 集合S 集合U
    1 选入A
    S={A(0)}
    以A为中间点开始找
    U = {B(6), C(3), D(∞), E(∞), F(∞)
    2 选入C
    S = {A(0), C(3)}
    以A->C开始找,若为最短路径则更新U
    U = {B(5), D(6), E(7), F(∞)}
    3 选入B
    S = {A(0), C(3), B(5)} 以A-B开始找,若为最短路径则更新U
    U = {D(6), E(7), F(∞)}
    4 S = {A(0), C(3), B(5), D(6)} U = {E(7), F(9)}
    5 S = {A(0), C(3), B(5), D(6), E(7)} U = F(9)
    6 S = {A(0), C(3), B(5), D(6), E(7), F(9)} U 集合为空

    按最短路径长度的递增次序依次把第二组的顶点加入S中。在加入的过程中,总保持从源点v到S中各顶点的最短路径长度不大于从源点v到U中任何顶点的最短路径长度

    代码

    #include <iostream>
    #include <algorithm>
    using namespace std;
    int n, m, c1, c2;
    int e[510][510], weight[510], dis[510], num[510], w[510];
    bool visit[510];
    const int inf = 99999999;
    int main() {
        scanf("%d%d%d%d", &n, &m, &c1, &c2);
        for(int i = 0; i < n; i++)
            scanf("%d", &weight[i]);
        fill(e[0], e[0] + 510 * 510, inf);
        fill(dis, dis + 510, inf);
        int a, b, c;
        for(int i = 0; i < m; i++) {
            scanf("%d%d%d", &a, &b, &c);
            e[a][b] = e[b][a] = c;
        }
        dis[c1] = 0;
        w[c1] = weight[c1];
        num[c1] = 1;
        for(int i = 0; i < n; i++) {
            int u = -1, minn = inf;
            for(int j = 0; j < n; j++) {
                if(visit[j] == false && dis[j] < minn) {
                    u = j;
                    minn = dis[j];
                }
            }
            if(u == -1) break;
            visit[u] = true;
            for(int v = 0; v < n; v++) {
                if(visit[v] == false && e[u][v] != inf) {
                    if(dis[u] + e[u][v] < dis[v]) {
                        dis[v] = dis[u] + e[u][v];
                        num[v] = num[u];
                        w[v] = w[u] + weight[v];
                    } else if(dis[u] + e[u][v] == dis[v]) {
                        num[v] = num[v] + num[u];
                        if(w[u] + weight[v] > w[v])
                            w[v] = w[u] + weight[v];
                    }
                }
            }
        }
        printf("%d %d", num[c2], w[c2]);
        return 0;
    }
    

    参考代码:日吹柳神

    总结

    1. 使用fill的时候,注意是fill一维矩阵还是二维矩阵
    int dis[500];
    int E[500][500];
    fill(dis,dis+500,inf); //对一维矩阵
    fill(E[0],E[0]+500*500,inf);//对二维矩阵
    
    1. 注意fill和memset区别
      其中fill能用的范围更广,而memset一般用于初始化char数组、string,如果用于初始化int数组的话只能填入0或1
      具体用法:fill和memset区别

    相关文章

      网友评论

          本文标题:PAT1003 Emergency (25)(Dijkstra算

          本文链接:https://www.haomeiwen.com/subject/rezhxqtx.html