美文网首页
PAT Advanced 1027. Colors in Mar

PAT Advanced 1027. Colors in Mar

作者: OliverLew | 来源:发表于2020-04-29 00:01 被阅读0次

    我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

    题目

    People in Mars represent the colors in their computers in a similar way as the
    Earth people. That is, a color is represented by a 6-digit number, where the
    first 2 digits are for Red, the middle 2 digits for Green, and the last 2
    digits for Blue. The only difference is that they use radix 13 (0-9 and A-C)
    instead of 16. Now given a color in three decimal numbers (each between 0 and
    168), you are supposed to output their Mars RGB values.

    Input Specification:

    Each input file contains one test case which occupies a line containing the
    three decimal color values.

    Output Specification:

    For each test case you should output the Mars RGB value in the following
    format: first output #, then followed by a 6-digit number where all the
    English characters must be upper-cased. If a single color is only 1-digit
    long, you must print a 0 to its left.

    Sample Input:

    15 43 71
    

    Sample Output:

    #123456
    

    思路

    很简单的一道题,13进制的转换

    代码

    最新代码@github,欢迎交流

    #include <stdio.h>
    
    int main()
    {
        int n, DIGITS = 3;
        char convert[] = "0123456789ABC";
        printf("#");
    
        for(int i = 0; i < DIGITS; i++)
        {
            scanf("%d", &n);
            printf("%c%c", convert[n / 13], convert[n % 13]);
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:PAT Advanced 1027. Colors in Mar

          本文链接:https://www.haomeiwen.com/subject/uacwwhtx.html