美文网首页
2020-03-17

2020-03-17

作者: joker_luo | 来源:发表于2020-03-17 17:07 被阅读0次

    1073 Scientific Notation(20分)

    Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

    Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

    Input Specification:

    Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

    Output Specification:

    For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

    Sample Input 1:

    +1.23400E-03
    
          
        
    

    Sample Output 1:

    0.00123400
    
          
        
    

    Sample Input 2:

    -1.2E+10
    
          
        
    

    Sample Output 2:

    -12000000000
    
    #include<iostream>
    #include<string>
    #include<math.h>
    using namespace std;
    int main(){
        string str;
        char symbol;//symbol标志正负 
        scanf("%c",&symbol);
        cin>>str;
        int length = str.length();
        int index=0;
        //找到E的位置,index+1是次数符号 
        while(1){
            if(str[index]=='E'){
                break;
            }
            index++;
        }
        string t = str.substr(index+2); 
        int tLength = t.length();
        int num = 0;
        int id = 0;
        for(int i=tLength-1;i>=0;--i){
            num += (t[i]-'0')*pow(10,id++);
        }
        if(str[index+1]=='-')
            num = -num;
        if(symbol=='-')
            printf("-");
        if(num<0){
            num = abs(num);
            printf("0.");
            for(int i=0;i<num-1;++i){
                printf("0");
            }
            for(int i=0;i<index;++i){
                if(str[i]=='.')
                    continue;
                printf("%c",str[i]);
            }
            printf("\n");
        }else{
            printf("%c",str[0]);
            if(index-2<=num){
                for(int i=2;i<index;++i){
                    printf("%c",str[i]);
                }
                for(int i=index;i<num+2;++i){
                    printf("0");
                }
            }
            else{
                //不用补零的情况
                for(int i=2;i<num+2;++i){
                    printf("%c",str[i]);
                }
                printf("."); 
                for(int i=num+2;i<index;++i){
                    printf("%c",str[i]);
                }
            }
        }   
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:2020-03-17

          本文链接:https://www.haomeiwen.com/subject/ukztyhtx.html