1002. A+B for Polynomials (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
2、注意
3、代码
#include<iostream>
#define N 1001
using namespace std;
int main() {
int n1, n2,i,j;
float f[N] = { 0 };
int a;
float b;
int max = 0, num = 0;
cin >> n1;
for (i = 0;i < n1;++i) {
scanf("%d %f", &a, &b);
f[a] += b;
if (a > max)
max = a;
}
cin >> n2;
//读入数据
for (i = 0;i < n2;++i) {
scanf("%d %f", &a, &b);
f[a] += b;
if (a > max)
max = a;
}
//求解非零总项数
for (i = max;i >= 0;--i) {
if (f[i] != 0) {
num++;
}
}
//输出结果
printf("%d", num);
for (i = max;i >= 0;--i) {
if (f[i] != 0) {
printf(" %d %.1f", i,f[i]);
}
}
system("pause");
return 0;
}
网友评论