美文网首页
【MAC 上学习 C++】Day 54-1. 实验11-1-3

【MAC 上学习 C++】Day 54-1. 实验11-1-3

作者: RaRasa | 来源:发表于2019-10-17 20:35 被阅读0次

    实验11-1-3 查找星期 (15 分)

    1. 题目摘自

    https://pintia.cn/problem-sets/13/problems/590

    2. 题目内容

    本题要求实现函数,可以根据下表查找到星期,返回对应的序号。

    序号 星期
    0 Sunday
    1 Monday
    2 Tuesday
    3 Wednesday
    4 Thursday
    5 Friday
    6 Saturday
    函数接口定义:

    int getindex( char *s );
    函数getindex应返回字符串s序号。如果传入的参数s不是一个代表星期的字符串,则返回-1。

    输入样例1:

    Tuesday

    输出样例1:

    2

    输入样例2:

    today

    输出样例2:

    wrong input!

    3. 源码参考
    #include <iostream>
    #include <string.h>
    
    using namespace std;
    
    #define MAXS 80
    
    int getindex( char *s );
    
    int main()
    {
        int n;
        char s[MAXS];
    
        cin >> s;
        n = getindex(s);
        if ( n==-1 ) 
        {
          cout << "wrong input!" << endl;
        }
        else
        {
          cout << n << endl;
        }
    
        return 0;
    }
    
    int getindex( char *s )
    {
      const char *m[12] = {"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"};
      
      for(int i = 0; i < 7; i++)
      {
        if(strcmp(s, m[i]) == 0)
        {
          return i;
        }
      }
    
      return -1;
    }
    

    相关文章

      网友评论

          本文标题:【MAC 上学习 C++】Day 54-1. 实验11-1-3

          本文链接:https://www.haomeiwen.com/subject/vkwxmctx.html