美文网首页
1022 Digital Library (30 分)

1022 Digital Library (30 分)

作者: W杂货铺W | 来源:发表于2018-10-29 11:48 被阅读0次

    A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​ ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

    • Line #1: the 7-digit ID number;
    • Line #2: the book title -- a string of no more than 80 characters;
    • Line #3: the author -- a string of no more than 80 characters;
    • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
    • Line #5: the publisher -- a string of no more than 80 characters;
    • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].
      It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

    After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

    • 1: a book title
    • 2: name of an author
    • 3: a key word
    • 4: name of a publisher
    • 5: a 4-digit number representing the year

    Output Specification:

    For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

    Sample Input:

    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords

    4: ZUCS Print
    5: 2011
    3: blablabla

    Sample Output:

    1: The Testing Book
    1111111
    2222222
    2: Yue Chen
    1111111
    3333333
    3: keywords
    1111111
    2222222
    3333333
    4: ZUCS Print
    1111111
    5: 2011
    1111111
    2222222
    3: blablabla
    Not Found

    分析

    • 采用map<string,set<int>>来储存每一个tag下的书本id,查找时将对应key下的set输出即可;

    • 输入keyword时,每次cingetchar,根据是否为'\n'判断keywords这一行是否结束

    while(cin >> tkey){
        key[tkey].insert(id);
        char c=getchar();
        if(c=='\n') break;
    }
    
    #include <iostream>
    #include <map>
    #include <set>
    
    using namespace std;
    
    map<string,set<int>> title,author,key,pub,year;
    
    void query(map<string,set<int>> &m, string &str){
        if(m.find(str)!=m.end()){
            for(auto it=m[str].begin();it!=m[str].end();it++){
                printf("%07d\n",*it);
            }
        }else{
            printf("Not Found\n");
        }
    }
    
    int main()
    {
        int n,id,nq,tag;
        string ttitle,tauthor,tkey,tpub,tyear,temp;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d\n",&id);
            getline(cin,ttitle);
            title[ttitle].insert(id);
            getline(cin,tauthor);
            author[tauthor].insert(id);
            while(cin >> tkey){
                key[tkey].insert(id);
                char c=getchar();
                if(c=='\n') break;
            }
            getline(cin,tpub);
            pub[tpub].insert(id);
            getline(cin,tyear);
            year[tyear].insert(id);
        }
        scanf("%d",&nq);
        for(int i=0;i<nq;i++){
            scanf("%d: ",&tag);
            getline(cin,temp);
            cout << tag << ": " << temp << endl;
            if(tag==1) query(title,temp);
            if(tag==2) query(author,temp);
            if(tag==3) query(key,temp);
            if(tag==4) query(pub,temp);
            if(tag==5) query(year,temp);
        }
    }
    

    参考

    相关文章

      网友评论

          本文标题:1022 Digital Library (30 分)

          本文链接:https://www.haomeiwen.com/subject/wgcbtqtx.html