题目:
Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
Sample Input
1
0.1
2
0.1 0.4
Sample Output
10.000
10.500
题意就是给你需要收集的卡片以及收集每种卡片的概率,问需要买多少个包才能收集齐(期望)。
分类:概率dp
其实我也不太明白概率dp的原理, 先把代码打上。
参考代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 20+2;
//0: 这种卡片没有收集到; 1: 这种卡片收集到了;
double p[MAXN];
double dp[1<<MAXN];//当前已经集齐的卡片的状态的情况下, 收集完所有卡片需要买东西次数的期望;
//包装袋中可能:
//1. 没有卡片;
//2. 卡片是已经收集到的;
//3. 卡片是没有收集到的;
//dp[1<<20]: 卡片最多20种, 每一种都有两种情况: 收集到 or 没有收集到;
void input(int n, double &tt) {
for (int i = 0;i < n;++i) {
scanf("%lf", &p[i]);
tt += p[i];//有卡片的概率;
}
}
int main() {
int n;
while (scanf("%d", &n) != EOF) {
double tt = 0;
//init();
input(n, tt);
tt = 1 - tt;//没有卡片的概率;
dp[(1<<n)-1] = 0;//所有的卡片都已收集齐, 期望为0;
for (int i = (1<<n)-2;i >= 0;--i) {//从还有一件没有集齐开始计算;
double x = 0, sum = 1;
for (int j = 0;j < n;++j) {//枚举每一种卡片;
if (i & (1<<j)) {//第j种卡片已经收集到了, 即i从右往左数第j位是1;
x += p[j];
}
else {
sum += p[j] * dp[i | (1<<j)];
}
}
dp[i] = sum / (1 - tt - x);
}
printf("%.5f\n", dp[0]);
}//dp[0]: 没有收集任何卡片种类的状态的情况下, 收集完所有卡片需要买东西次数的期望;
return 0;
}
网友评论