一种排序
时间限制:3000 ms | 内存限制:65535 KB
现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);
1.按照编号从小到大排序
2.对于编号相等的长方形,按照长方形的长排序;
3.如果编号和长都相同,按照长方形的宽排序;
4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
输入
第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,
第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
输出
顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
样例输入
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1
样例输出
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1
题目很简单。我这里用的是结构体加set。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
using namespace std;
struct rec{
int id;
int x;
int y;
bool operator < (const rec& b) const{
if(id!=b.id)
return id<b.id;
else{
if(x!=b.x)
return x<b.x;
else
return y<b.y;
}
}
}temp;
set<rec> rect;
int main(){
int N;
cin>>N;
while (N--){
int n;
cin>>n;
for(int i=0;i<n;i++){
cin>>temp.id>>temp.x>>temp.y;
if(temp.x<temp.y){
int x=temp.x;
temp.x=temp.y;
temp.y=x;
}
rect.insert(temp);
}
set<rec>::iterator it;
for(it=rect.begin();it!=rect.end();it++){
cout<<it->id<<" "<<it->x<<" "<<it->y<<endl;
}
rect=set<rec>();
}
}
网友评论