美文网首页
1021 Deepest Root (25 分)

1021 Deepest Root (25 分)

作者: W杂货铺W | 来源:发表于2018-10-27 23:19 被阅读0次

A graph which is connected and acyclic can be considered a tree. The hight of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​ ) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

分析

  • 首先从任意节点通过dfs得到连通分量的个数
for(node in node_set){
   if(visit[node]==false) dfs(node);
   cnt++;
}
  • 在dfs函数中设置参数保存当前长度,递归时深度加1,求取当前最大深度,并将这些节点保存到temp向量中
void dfs(int node,int height){
    if(height>maxheight){
        temp.clear();
        temp.push_back(node);
        maxheight=height;
    }else if(height==maxheight){
        temp.push_back(node);
    }
    ...
}
  • dfs一次后把temp中元素插入集合s
  • 在这些节点中任意一个进行dfs,得到的节点跟上一步的节点的并集即为结果。
#include <iostream>
#include <algorithm>
#include <vector>
#include <set>
using namespace std;

int n;
int maxheight=0;


vector<int> v[10010];
vector<int> temp;
bool visit[10010];
set<int> s;
void dfs(int node,int height){
    if(height>maxheight){
        temp.clear();
        temp.push_back(node);
        maxheight=height;
    }else if(height==maxheight){
        temp.push_back(node);
    }
    visit[node]=true;
    for(int i=0;i<v[node].size();i++){
        if(visit[v[node][i]]==false){
            dfs(v[node][i],height+1);
        }
    }
}

int main()
{
    int cnt=0;
    int sr;
    int a,b;
    scanf("%d",&n);
    for(int i=1;i<n;i++){
        scanf("%d%d",&a,&b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    for(int i=1;i<=n;i++){
        if(visit[i]==false){
            dfs(i,0);
            cnt++;
            sr = temp[0];
            for(int j=0;j<temp.size();j++){
                s.insert(temp[j]);
            }
        }
    }
    if(cnt!=1){
       printf("Error: %d components",cnt);
    }else{
        fill(visit,visit+10010,false);
        temp.clear();
        dfs(sr,0);
        for(int i=0;i<temp.size();i++){
            s.insert(temp[i]);
        }
        for(auto it=s.begin();it!=s.end();it++){
            printf("%d\n",*it);
        }
    }
}

参考

相关文章

网友评论

      本文标题:1021 Deepest Root (25 分)

      本文链接:https://www.haomeiwen.com/subject/aobstqtx.html