传送门
题目
“答案正确”是自动判题系统给出的最令人欢喜的回复。本题属于PAT的“答案正确”大派送 —— 只要读入的字符串满足下列条件,系统就输出“答案正确”,否则输出“答案错误”。
得到“答案正确”的条件是:
1.字符串中必须仅有P, A, T这三种字符,不可以包含其它字符;
2.任意形如 xPATx 的字符串都可以获得“答案正确”,其中 x 或者是空字符串,或者是仅由字母 A 组成的字符串;
3.如果 aPbTc 是正确的,那么 aPbATca 也是正确的,其中 a, b, c 均或者是空字符串,或者是仅由字母 A 组成的字符串。
现在就请你为PAT写一个自动裁判程序,判定哪些字符串是可以获得“答案正确”的。
输入格式: 每个测试输入包含1个测试用例。第1行给出一个自然数n (<10),是需要检测的字符串个数。接下来每个字符串占一行,字符串长度不超过100,且不包含空格。
输出格式:每个字符串的检测结果占一行,如果该字符串可以获得“答案正确”,则输出YES,否则输出NO。
输入样例:
8
PAT
PAAT
AAPATAA
AAPAATAAAA
xPATx
PT
Whatever
APAAATAA
输出样例:
YES
YES
YES
YES
NO
NO
NO
NO
提交代码
#include <stdio.h>
#include <string.h>
int main()
{
freopen("D:\\C\\test.txt","r",stdin);//测试文件路径
char test[10][105];//存放数据
int n,cnt;
int yorn[10] = {0};
scanf("%d", &n);
//读入数据
for ( cnt=0; cnt<n; cnt++ ) scanf("%s", &test[cnt]);
for ( cnt=0; cnt<n; cnt++ ) {
char *testp = test[cnt];
int flagP=0, flagT=0, pointP=0, pointT=0,length=0,xushu=0;//P与T的个数以及PT的位置
while ( *testp=='P' || *testp=='A' || *testp=='T') {
if (*testp=='P') {
pointP = xushu;
flagP++;
}
if (*testp=='T') {
pointT = xushu;
flagT++;
}
*testp++;
length++;
xushu++;
}
if ( *testp || flagP!=1 || flagT!=1 ) yorn[cnt] = 1;
else if ( pointP==0 && test[cnt][length-1]=='T' ) {
if ( (pointT-pointP)<=1 ) yorn[cnt] = 1;
}else if ( (pointT-pointP)<=1 ) yorn[cnt] = 1;
else {
int Afront=0, Amiddle=0, Abehind=0;//计算A的个数是否满足条件
testp = &test[cnt][0];
while (*testp++=='A')Afront++;
while (*testp++=='A')Amiddle++;
while (*testp++=='A')Abehind++;
if ( Amiddle*Afront!=Abehind ) yorn[cnt] = 1;
}
}
//输出结果
for ( cnt=0; cnt<n; cnt++ ) {
if (yorn[cnt]) printf("NO\n");
else printf("YES\n");
}
return 0;
}
网友评论