- PAT 甲级 刷题日记|A 1150 Travelling Sa
- PAT A1001 A+B Format (20)
- PAT 甲级 刷题日记|A 1122 Hamiltonian
- PAT 甲级 刷题日记|A 1123 Is It a Compl
- PAT 甲级 刷题日记|A 1038 Recover the
- PAT 甲级 刷题日记|A 1043 Is It a Bina
- PAT 甲级 刷题日记|A 1129 Recommendatio
- PAT 甲级 刷题日记|A 1127 ZigZagging on
- PAT 甲级 刷题日记|A 1094 The Largest
- PAT 甲级 刷题日记|A 1135 Is It A Red
题目
The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)
In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist
, where the cities are numbered from 1 to N and the distance Dist
is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:
n C1 C2 ... Cn
where n is the number of cities in the list, and Ci's are the cities on a path.
Output Specification:
For each path, print in a line Path X: TotalDist (Description)
where X
is the index (starting from 1) of that path, TotalDist
its total distance (if this distance does not exist, output NA
instead), and Description
is one of the following:
-
TS simple cycle
if it is a simple cycle that visits every city; -
TS cycle
if it is a cycle that visits every city, but not a simple cycle; -
Not a TS cycle
if it is NOT a cycle that visits every city.
Finally print in a line Shortest Dist(X) = TotalDist
where X
is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist
is its total distance. It is guaranteed that such a solution is unique.
Sample Input:
6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6结尾无空行
Sample Output:
Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8结尾无空行
思路:
带权路径的存储:最方便的是用邻接矩阵
判断 三种情况 两层判断:
- 是否为旅行商路径:所有点均访问过, 是否构成了环(中间有没有不可达的路径,首尾点是否一致)
- 在满足上述条件的基础上:所有点是否仅被访问过一次
代码
#include <bits/stdc++.h>
using namespace std;
const int maxn = 202;
int graph[maxn][maxn];
int main() {
int n, m, from, to, length;
cin>>n>>m;
for (int i = 0; i < m; i++) {
cin>>from>>to>>length;
graph[from][to] = length;
graph[to][from] = length;
}
int cnt;
cin>>cnt;
int sum;
int mindis = INT_MAX - 1;
int minid = 0;
for (int i = 1; i <= cnt; i++) {
cin>>sum;
int dis = 0;
vector<int> path(sum);
set<int> s;
for (int j = 0; j < sum; j++) {
cin>>path[j];
s.insert(path[j]);
}
for (int j = 1; j < sum; j++) {
if (graph[path[j]][path[j-1]]!= 0) {
dis += graph[path[j]][path[j-1]];
} else {
dis = INT_MAX;
break;
}
}
if (s.size() == n && dis < mindis && path[sum-1] == path[0]) {
mindis = dis;
minid = i;
}
if (dis != INT_MAX) printf("Path %d: %d ", i, dis);
else printf("Path %d: NA ", i);
if (s.size() == sum - 1 && s.size() == n && dis != INT_MAX && path[sum-1] == path[0])
printf("(TS simple cycle)\n");
else if (s.size() == n && dis != INT_MAX && path[sum-1] == path[0])
printf("(TS cycle)\n");
else printf("(Not a TS cycle)\n");
}
printf("Shortest Dist(%d) = %d", minid, mindis);
}
网友评论