题目:
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS
, and ID_number
is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
解题思路:
将测试用例存储起来,查找其中 Sign In 时间点的最小值和 Sign Out 时间的最大值即可。
代码:
编译器:C++(g++)
#include <iostream>
#include <string>
#include <vector>
using namespace std;
struct Info{
string id;
int inTime;
int outTime;
Info(const string &s,int i,int o):id(s),inTime(i),outTime(o){}
};
int stosec(const string &s)
{
int hh=(s[0]-'0')*10+s[1]-'0';
int mm=(s[3]-'0')*10+s[4]-'0';
int ss=(s[6]-'0')*10+s[7]-'0';
return hh*3600+mm*60+ss;
}
int main()
{
int m;
cin>>m;
if(0==m)
{
return 0;
}
vector<Info> lst;
for(int i=0;i!=m;++i)
{
string s1,s2,s3;
cin>>s1>>s2>>s3;
Info inf(s1,stosec(s2),stosec(s3));
lst.push_back(inf);
}
int min=-1,minIndex=-1,max=-1,maxIndex=-1;
for(int i=0;i!=m;++i)
{
if(-1==min)
{
min=lst[i].inTime;
minIndex=i;
}
else
{
if(lst[i].inTime<min)
{
min=lst[i].inTime;
minIndex=i;
}
}
if(-1==max)
{
max=lst[i].outTime;
maxIndex=i;
}
else
{
if(lst[i].outTime>max)
{
max=lst[i].outTime;
maxIndex=i;
}
}
}
cout<<lst[minIndex].id<<" "<<lst[maxIndex].id<<endl;
return 0;
}
网友评论