美文网首页
PTA 03-树3 Tree Traversals Again

PTA 03-树3 Tree Traversals Again

作者: lucas_cc | 来源:发表于2018-04-21 14:34 被阅读0次

采用Divide and Conquer(分而治之)的思想进行解决。

1. 题目描述

03-树3 Tree Traversals Again(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2Nlines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

2.代码实现

/* don't build a tree */
#include <stdio.h>
#include <string.h>
#define MAXSIZE 30

typedef int DataType;
DataType Pre[MAXSIZE], In[MAXSIZE], Post[MAXSIZE];

void TreeTraversalsAgain(int preP, int inP, int postP, int n);
void OutPut(DataType a[], int n);

int main()
{
    int n, tmp, i, j = 0;
    int topPre = -1;
    int topIn  = -1;
    const char * Push = "Push";
    char Operation[5];
    DataType S[MAXSIZE];

    scanf("%d", &n);
    for (i = 0; i < 2 * n; i++) {
        scanf("\n%s", Operation);
        if (!strcmp(Operation, Push)) {
            scanf("%d", &tmp);
            Pre[j++] = tmp;
            S[++topPre] = tmp;
        } else {
            In[++topIn] = S[topPre--];
        }
    }
    TreeTraversalsAgain(0, 0, 0, n);
    OutPut(Post, n);

    return 0;
}

/* divide and conquer */
void TreeTraversalsAgain(int preP, int inP, int postP, int n)
{
    int i, cntL, cntR;
    DataType root;
    if (!n) return;
    if (n == 1) {
        Post[postP] = Pre[preP];
        return;
    }
    root = Pre[preP];
    Post[postP + n - 1] = root;
    for (i = 0; i < n; i++)
        if (In[inP + i] == root) break;
    cntL = i;
    cntR = n - cntL - 1;
    TreeTraversalsAgain(preP + 1, inP, postP, cntL);
    TreeTraversalsAgain(preP + cntL + 1, inP + cntL + 1, postP + cntL, cntR);
}

void OutPut(DataType a[], int n)
{
    int i;
    for (i = 0; i < n; i++) {
        if (!i)
            printf("%d", a[i]);
        else
            printf(" %d", a[i]);
    }
    return;
}

相关文章

网友评论

      本文标题:PTA 03-树3 Tree Traversals Again

      本文链接:https://www.haomeiwen.com/subject/oojxlftx.html