美文网首页
2020-04-09

2020-04-09

作者: joker_luo | 来源:发表于2020-04-09 21:09 被阅读0次

    1061 Dating (20分)

    Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

    Input Specification:

    Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

    Output Specification:

    For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

    Sample Input:

    3485djDkxh4hhGE 
    2984akDfkkkkggEdsb 
    s&hgsfdk 
    d&Hyscvnm
    
          
        
    

    Sample Output:

    THU 14:04
    
    #include<iostream>
    #include<string>
    using namespace std;
    int min(int a,int b){
        int temp = a;
        if(a>b){
            temp = b;
        }
        return temp;    
    }
    int main(){
        string day[7] = {"MON","TUE","WED","THU","FRI","SAT","SUN"};
        string str1,str2,str3,str4;
        cin>>str1>>str2>>str3>>str4;
        int l1 = str1.length();
        int l2 = str2.length();
        int l3 = str3.length();
        int l4 = str4.length();
        int min1 = max(l1,l2);
        int min2 = max(l3,l4);
        char arr_str[2];
        int i=0;
        for(i;i<min1;++i){
            if(str1[i]==str2[i]&&str1[i]>='A'&&str1[i]<='G'){
                arr_str[0] = str1[i];
                break;
            }
        }
        i++;
        for(i;i<min1;++i){
            if(str1[i]==str2[i]&&str1[i]>='A'&&str1[i]<='N' || str1[i]==str2[i]&&isdigit(str1[i])){
                arr_str[1] = str1[i];
                break;
            }
        }
        int min;
        for(int i=0;i<min2;++i){
            if(str3[i]==str4[i]&&isalpha(str3[i])){
                min = i;
                break;  
            }
        }
        int hour = isdigit(arr_str[1]) ? arr_str[1] - '0' : arr_str[1] - 'A' + 10;
        cout<<day[arr_str[0]-'A']<<" ";
        printf("%02d:%02d",hour,min);
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:2020-04-09

          本文链接:https://www.haomeiwen.com/subject/spwhmhtx.html