美文网首页
甲级-1002 A+B for Polynomials (25

甲级-1002 A+B for Polynomials (25

作者: 梦终无痕_311d | 来源:发表于2019-09-27 16:57 被阅读0次

题目:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ...NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​​ <⋯<N2 <N1​​ ≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

解题思路:

使用 map 可以比较容易地解决这个问题。

代码:

编译器:C++(g++)

#include <iostream>
#include <iomanip>
#include <map>
#include <sstream>
using namespace std;

int main()
{
    map<int,double> mp;
    int k;
    while (cin >> k)
    {
        for (int i = 0; i != k; ++i)
        {
            int n;
            double a;
            cin >> n >> a;
            mp[n] += a;
        }
    }
    ostringstream oss;
    oss.flags(ostringstream::fixed);
    oss.precision(1);
    int count = 0;
    //倒序输出 map 中的元素
    for (auto it=mp.crbegin();it!=mp.crend();++it)
    {
        if (!(it->second<=1e-15&&it->second>=-1e-15))
        {
            oss << " " << it->first << " " << it->second;
            ++count;
        }
    }
    cout << count << oss.str() << endl;
    return 0;
}

相关文章

网友评论

      本文标题:甲级-1002 A+B for Polynomials (25

      本文链接:https://www.haomeiwen.com/subject/urjlyctx.html