美文网首页PAT
1011 World Cup Betting

1011 World Cup Betting

作者: 胖胖的熊管家 | 来源:发表于2020-04-19 11:07 被阅读0次

    题目

    赌博游戏,有三轮,每一轮有W,T,L三种选择。选出每一轮最大的赔率,然后通过公式(a * b * c * 65% -1) * 2来算利润。
    输出每一轮最大的赔率是哪个选择,最后输出利润(保留两位小数)。

    Sample Input
    1.1 2.5 1.7
    1.2 3.1 1.6
    4.1 1.2 1.1
    
    Sample Output
    T T W 39.31
    

    解法

    法一:C++
    思路:

    没啥,就是循环。

    源代码:
    #include <iostream>
    #include <cstdio>
    #include <math.h>
    #include<vector>
    #include <string.h>
    #include <sstream>
    using namespace std;
    
    int main() {
        double bet,result;
        char max[3] = {'W','T','L'};
        double temp;
        char tempchar[3];
        result = 1.0;
        for(int i=0;i<3;i++){
            temp=0;
            for(int j=0;j<3;j++){
                scanf("%lf",&bet);
                if(temp<bet){
                    temp = bet;
                    tempchar[i] = max[j];
                }
            }
            result *= temp;
        }
        
        result =(result * 0.65 - 1) * 2;
        
        for(int i=0;i<3;i++){
            cout<<tempchar[i]<<" ";
        }
        printf("%.2f",result);
        return 0;
    }
    

    知识点+坑:

    1.保留两位小数输出不是"%.01f",是"%.2f"。

    相关文章

      网友评论

        本文标题:1011 World Cup Betting

        本文链接:https://www.haomeiwen.com/subject/vzvnvhtx.html