美文网首页
uva-10935 Foreign Exchange

uva-10935 Foreign Exchange

作者: FD丶grass | 来源:发表于2017-01-22 11:24 被阅读0次

    题目

     Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task.
     The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

    Input

     The input file contains multiple cases. Each test case will consist of a line containing n – the number of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s original location and the candidate’s target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.

    Output

    For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out, otherwise print ‘NO’.

    Sample Input

    10
    1 2
    2 1
    3 4
    4 3
    100 200
    200 100
    57 2
    2 57
    1 2
    2 1
    10
    1 2
    3 4
    5 6
    7 8
    9 10
    11 12
    13 14
    15 16
    17 18
    19 20
    0

    Sample Output

    YES
    NO

    分析

    很简单的一个题,但是点的个数是未知,我用邻接表建图,然后删点,ac,很顺利。

    ac代码

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <list>
    using namespace std;
    const int maxn = 5e5 + 5;
    list <int> chart[maxn];
    void init(const int &);
    void solve(const int &);
    int main(){
        int n;
        while(scanf("%d", &n) && n){
            init(n);
            solve(n);
        }
        return 0;
    } 
    void init(const int &n){
        for(int i = 0; i < maxn; ++i){
            chart[i].clear();
        }
        for(int i = 0; i < n; ++i){
            int t1, t2;
            scanf("%d%d", &t1, &t2);
            chart[t1-1].push_back(t2 - 1);
        }
    }
    void solve(const int &n){
        for(int i = 0; i < maxn; ++i){
            while(!chart[i].empty()){
                int temp = *chart[i].begin();
                if(temp == i){
                    chart[i].pop_front();
                    continue;
                }
                chart[i].pop_front();
                for(list <int> :: iterator it = chart[temp].begin(); ; ++it){
                    if(it == chart[temp].end()){
                        printf("NO\n");
                        return;
                    }
                    else if(*it == i){
                        chart[temp].erase(it);
                        break;
                    }
                }
            }
        }
        printf("YES\n");
    }
    

    相关文章

      网友评论

          本文标题:uva-10935 Foreign Exchange

          本文链接:https://www.haomeiwen.com/subject/xztobttx.html