美文网首页
1009. Product of Polynomials (25

1009. Product of Polynomials (25

作者: 陈洲 | 来源:发表于2017-02-24 22:42 被阅读0次

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

#include <iostream>
#include <vector>
#include <algorithm> 
using namespace std;
vector<double> ans(2001,0);
vector<pair<int,double> > p1;
vector<pair<int,double> > p2;
bool compare(pair<int,double> a,pair<int,double> b)
{
    return a.first>b.first;
}
int main()
{
    int N,e;
    double c;
    cin >> N;
    for(int i=0; i<N; i++)
    {
        cin >> e >> c;
        p1.push_back(pair<int,double>(e,c));
    }
    cin >> N;
    for(int i=0; i<N; i++)
    {
        cin >> e >> c;
        p2.push_back(pair<int,double>(e,c));
    }
    for(int i=0; i<p1.size(); i++)
    {
        for(int j=0; j<p2.size(); j++)
        {
            e = p1[i].first + p2[j].first;
            c = p1[i].second * p2[j].second;
            ans[e] += c;
        }
    }
    p1.clear();
    for(int i=0; i<2001; i++)
    {
        if(ans[i]!=0)
            p1.push_back(pair<int,double>(i,ans[i]));
    }
    cout << p1.size() << " ";
    sort(p1.begin(),p1.end(),compare);
    for(int i=0; i<p1.size(); i++)
    {
        if(i!=0) cout << " ";
        printf("%d %.1f",p1[i].first,p1[i].second);
    }
    return 0;
}

相关文章

网友评论

      本文标题:1009. Product of Polynomials (25

      本文链接:https://www.haomeiwen.com/subject/yzcgwttx.html