美文网首页
1009 Product of Polynomials (25)

1009 Product of Polynomials (25)

作者: 沙_狸 | 来源:发表于2018-08-06 12:13 被阅读0次

    题目信息

    This time, you are supposed to find A*B where A and B are two polynomials.
    Input Specification:
    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
    Output Specification:
    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
    Sample Input
    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    Sample Output
    3 3 3.6 2 6.0 1 1.6

    代码

    #include<iostream>
    using namespace std;
    int main(){
        int k1,k2,ex,cnt=0;
        scanf("%d",&k1);
        double co,a[2002]={0},ans[2002]={0};
        for(int i=0;i<k1;i++){
            scanf("%d",&ex);
            scanf("%lf",&a[ex]);
        }
        scanf("%d",&k2);
        for(int i=0;i<k2;i++){
            scanf("%d %lf",&ex,&co);
            for(int j=2001;j>=0;j--){
                if(a[j]!=0){
                    ans[j+ex]+=a[j]*co;
                }
            }
        }
        for(int i=0;i<2002;i++){
            if(ans[i]!=0) cnt++;
        }
        cout<<cnt;
        for(int i=2001;i>=0;i--){
            if(ans[i]!=0) printf(" %d %.1f",i,ans[i]);
        }
        return 0;
    }
    

    测试结果

    image.png

    相关文章

      网友评论

          本文标题:1009 Product of Polynomials (25)

          本文链接:https://www.haomeiwen.com/subject/yyiwvftx.html