我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo。
题目
To store English words, one method is to use linked lists and store a word
letter by letter. To save some space, we may let the words share the same
sublist if they share the same suffix. For example, loading
and being
are
stored as showed in Figure 1.
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the
position of i
in Figure 1).
Input Specification:
Each input file contains one test case. For each case, the first line contains
two addresses of nodes and a positive ( ), where the two
addresses are the addresses of the first nodes of the two words, and is
the total number of nodes. The address of a node is a 5-digit positive
integer, and NULL is represented by .
Then lines follow, each describes a node in the format:
Address Data Next
whereAddress
is the position of the node, Data
is the letter contained by
this node which is an English letter chosen from { a-z, A-Z }, and Next
is
the position of the next node.
Output Specification:
For each case, simply output the 5-digit starting position of the common
suffix. If the two words have no common suffix, output -1
instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
思路
一个链表相关的题目。
依然暴力地(再次说明,很不实用。不过最坏情况就需要这么多,所以对于OJ来说,不算浪费)申请一个100000长度的数组,直接用数组索引作为链表地址。
思路很简单:
记录链表:
结构数组[Address] => 结构数组[Next]
遍历第一个单词:
标记所有遍历的结点
遍历第二个单词:
输出第一个被标记的结点
我定义的结构只有下一个结点的地址和一个标记,没有记录字符,因为你会发现它没用。。。
盲点:单词开头地址可能为NULL
。盲生,你是否发现这个了华点?
代码
最新代码@github,欢迎交流
#include <stdio.h>
typedef struct Node Node;
struct Node {
int checked;
struct Node *next;
};
int main()
{
char data;
int start1, start2, address, next, N;
Node list[100000] = {0}, *p;
scanf("%d %d %d", &start1, &start2, &N);
/* record a linked list */
for(int i = 0; i < N; i++)
{
scanf("%d %c %d", &address, &data, &next);
list[address].next = next == -1 ? NULL : &list[next];
}
if(start1 == -1 || start2 == -1)
{
printf("-1");
return 0;
}
/* First traverse the first string */
for(p = list + start1; p; p = p->next)
p->checked = 1;
/* Then traverse the second looking for checked node */
for(p = list + start2; p && !p->checked; p = p->next)
;
if(p)
printf("%05ld", p - list);
else
printf("-1");
return 0;
}
网友评论